summaryrefslogtreecommitdiff
path: root/simplex-dev/CMakeLists.txt
diff options
context:
space:
mode:
authorPasha <pasha@member.fsf.org>2022-10-25 18:48:39 +0000
committerPasha <pasha@member.fsf.org>2022-10-25 18:48:39 +0000
commit4550eacc18535ea8480c8303c62adbd046fa031d (patch)
tree39c850531e37a9ae6d390ac35cf21a6029d5b5e7 /simplex-dev/CMakeLists.txt
downloadoneapi-4550eacc18535ea8480c8303c62adbd046fa031d.tar.gz
oneapi-4550eacc18535ea8480c8303c62adbd046fa031d.tar.bz2
initial test
Diffstat (limited to 'simplex-dev/CMakeLists.txt')
-rwxr-xr-xsimplex-dev/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/simplex-dev/CMakeLists.txt b/simplex-dev/CMakeLists.txt
new file mode 100755
index 0000000..413315c
--- /dev/null
+++ b/simplex-dev/CMakeLists.txt
@@ -0,0 +1,20 @@
+if(UNIX)
+ # Direct CMake to use dpcpp rather than the default C++ compiler/linker
+ set(CMAKE_CXX_COMPILER dpcpp)
+else() # Windows
+ # Force CMake to use dpcpp rather than the default C++ compiler/linker
+ # (needed on Windows only)
+ include (CMakeForceCompiler)
+ CMAKE_FORCE_CXX_COMPILER (dpcpp IntelDPCPP)
+ include (Platform/Windows-Clang)
+endif()
+
+cmake_minimum_required (VERSION 3.4)
+
+project(FastRecompile CXX)
+
+set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+
+add_subdirectory (src)