aboutsummaryrefslogtreecommitdiff
path: root/web/NetUseAdminWeb/Makefile.PL
diff options
context:
space:
mode:
authorPasha <pasha@member.fsf.org>2024-01-20 10:09:23 +0000
committerPasha <pasha@member.fsf.org>2024-01-20 10:09:23 +0000
commit76669f6c298bcf3f69a0e1df5c524a7cff3e367d (patch)
tree9704c3470c1f3ca91510d9af01b8e8eb81969ed9 /web/NetUseAdminWeb/Makefile.PL
downloadnetusemod-master.tar.gz
netusemod-master.tar.bz2
initial commitHEADmaster
Diffstat (limited to 'web/NetUseAdminWeb/Makefile.PL')
-rw-r--r--web/NetUseAdminWeb/Makefile.PL42
1 files changed, 42 insertions, 0 deletions
diff --git a/web/NetUseAdminWeb/Makefile.PL b/web/NetUseAdminWeb/Makefile.PL
new file mode 100644
index 0000000..0054f7d
--- /dev/null
+++ b/web/NetUseAdminWeb/Makefile.PL
@@ -0,0 +1,42 @@
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+# NetUseMod is a program to moderate Usenet posts via web interface.
+# Copyright (C) 2024 Salahuddin <salahuddin@member.fsf.org>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Normalize version strings like 6.30_02 to 6.3002,
+# so that we can do numerical comparisons on it.
+my $eumm_version = $ExtUtils::MakeMaker::VERSION;
+$eumm_version =~ s/_//;
+
+WriteMakefile(
+ NAME => 'NetUseAdminWeb',
+ AUTHOR => q{YOUR NAME <youremail@example.com>},
+ VERSION_FROM => 'lib/NetUseAdminWeb.pm lib/NetUseAdminWeb.pm',
+ ABSTRACT => 'YOUR APPLICATION ABSTRACT',
+ ($eumm_version >= 6.3001
+ ? ('LICENSE'=> 'perl')
+ : ()),
+ PL_FILES => {},
+ PREREQ_PM => {
+ 'Test::More' => 0,
+ 'YAML' => 0,
+ 'Dancer2' => 0.400001,
+ },
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'NetUseAdminWeb-*' },
+);