aboutsummaryrefslogtreecommitdiff
path: root/autotests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'autotests/CMakeLists.txt')
-rw-r--r--autotests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/autotests/CMakeLists.txt b/autotests/CMakeLists.txt
index 6d259881..96c7b65e 100644
--- a/autotests/CMakeLists.txt
+++ b/autotests/CMakeLists.txt
@@ -16,7 +16,8 @@ if(NOT Qt5Concurrent_FOUND)
return()
endif()
-set(kentrymaptest_SRCS kentrymaptest.cpp)
+# compile KEntryMap into the test since it's not exported
+set(kentrymaptest_SRCS kentrymaptest.cpp ../src/core/kconfigdata.cpp)
ecm_add_test(${kentrymaptest_SRCS}
TEST_NAME kentrymaptest
LINK_LIBRARIES KF5::ConfigCore Qt5::Test