aboutsummaryrefslogtreecommitdiff
path: root/autotests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'autotests/CMakeLists.txt')
-rw-r--r--autotests/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/autotests/CMakeLists.txt b/autotests/CMakeLists.txt
index cae4c0b1..a7e37e5a 100644
--- a/autotests/CMakeLists.txt
+++ b/autotests/CMakeLists.txt
@@ -1,14 +1,14 @@
include(ECMAddTests)
-find_package(Qt5Test ${REQUIRED_QT_VERSION} CONFIG QUIET)
-find_package(Qt5Concurrent ${REQUIRED_QT_VERSION} CONFIG QUIET)
+find_package(Qt${QT_MAJOR_VERSION}Test ${REQUIRED_QT_VERSION} CONFIG QUIET)
+find_package(Qt${QT_MAJOR_VERSION}Concurrent ${REQUIRED_QT_VERSION} CONFIG QUIET)
-if(NOT Qt5Test_FOUND)
+if(NOT Qt${QT_MAJOR_VERSION}Test_FOUND)
message(STATUS "Qt5Test not found, autotests will not be built.")
return()
endif()
-if(NOT Qt5Concurrent_FOUND)
+if(NOT Qt${QT_MAJOR_VERSION}Concurrent_FOUND)
message(STATUS "Qt5Concurrent not found, autotests will not be built.")
return()
endif()
@@ -18,7 +18,7 @@ ecm_add_test(
kentrymaptest.cpp
../src/core/kconfigdata.cpp
TEST_NAME kentrymaptest
- LINK_LIBRARIES Qt5::Test
+ LINK_LIBRARIES Qt${QT_MAJOR_VERSION}::Test
)
target_include_directories(kentrymaptest PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/../src/core)
@@ -27,17 +27,17 @@ ecm_add_test(
test_kconfigutils.cpp
../src/kconf_update/kconfigutils.cpp
TEST_NAME test_kconfigutils
- LINK_LIBRARIES KF5::ConfigCore Qt5::Test
+ LINK_LIBRARIES KF5::ConfigCore Qt${QT_MAJOR_VERSION}::Test
)
target_include_directories(test_kconfigutils PRIVATE ../src/kconf_update)
qt_add_resources(sharedconfigresources sharedconfigresources.qrc)
-ecm_add_test(ksharedconfigtest.cpp ${sharedconfigresources} TEST_NAME kconfigcore-ksharedconfigtest LINK_LIBRARIES KF5::ConfigCore Qt5::Test Qt5::Concurrent)
+ecm_add_test(ksharedconfigtest.cpp ${sharedconfigresources} TEST_NAME kconfigcore-ksharedconfigtest LINK_LIBRARIES KF5::ConfigCore Qt${QT_MAJOR_VERSION}::Test Qt${QT_MAJOR_VERSION}::Concurrent)
# test for fallback to :/kconfig/xxxx config resource
qt_add_resources(fallbackconfigresources fallbackconfigresources.qrc)
-ecm_add_test(fallbackconfigresourcestest.cpp ${fallbackconfigresources} TEST_NAME kconfigcore-fallbackconfigresourcestest LINK_LIBRARIES KF5::ConfigCore Qt5::Test Qt5::Concurrent)
+ecm_add_test(fallbackconfigresourcestest.cpp ${fallbackconfigresources} TEST_NAME kconfigcore-fallbackconfigresourcestest LINK_LIBRARIES KF5::ConfigCore Qt${QT_MAJOR_VERSION}::Test Qt${QT_MAJOR_VERSION}::Concurrent)
ecm_add_tests(
kconfignokdehometest.cpp
@@ -46,19 +46,19 @@ ecm_add_tests(
test_kconf_update.cpp
ksharedconfig_in_global_object.cpp
NAME_PREFIX kconfigcore-
- LINK_LIBRARIES KF5::ConfigCore Qt5::Test Qt5::Concurrent
+ LINK_LIBRARIES KF5::ConfigCore Qt${QT_MAJOR_VERSION}::Test Qt${QT_MAJOR_VERSION}::Concurrent
)
target_include_directories(test_kconf_update PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/../src/kconf_update)
-if(TARGET Qt5::Gui)
+if(TARGET Qt${QT_MAJOR_VERSION}::Gui)
ecm_add_tests(
kconfigguitest.cpp
kconfigloadertest.cpp
kconfigskeletontest.cpp
kstandardshortcuttest.cpp
NAME_PREFIX kconfiggui-
- LINK_LIBRARIES KF5::ConfigGui Qt5::Test
+ LINK_LIBRARIES KF5::ConfigGui Qt${QT_MAJOR_VERSION}::Test
)
# These tests do a global cleanup of ~/.qttest, so they can't run in parallel