aboutsummaryrefslogtreecommitdiff
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedrich W. H. Kossebau <kossebau@kde.org>2022-02-16 17:16:37 +0100
committerFriedrich W. H. Kossebau <kossebau@kde.org>2022-02-25 23:52:26 +0000
commit4a1710762b0a53d6a35e6d0cb630b9037a853c63 (patch)
treed6791446e76652f403ea3b13bc334df2ab244387 /src/core/CMakeLists.txt
parentf446af2aa592997f6bc4aa3b5559cf477f9259f8 (diff)
downloadkconfig-4a1710762b0a53d6a35e6d0cb630b9037a853c63.tar.gz
kconfig-4a1710762b0a53d6a35e6d0cb630b9037a853c63.tar.bz2
Remove broken Python bindings generation
pyqt broke sip4 compatibility in 5.15.6, and there is no more maintainer of the KF Python bindings to fix things. Future support might need different code, so no advantage in keeping the old code around.
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 7bed316b..ec1e4995 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -72,29 +72,6 @@ ecm_generate_headers(KConfigCore_HEADERS
REQUIRED_HEADERS KConfigCore_HEADERS
)
-find_package(PythonModuleGeneration)
-
-if (PythonModuleGeneration_FOUND)
- ecm_generate_python_binding(
- TARGET KF5::ConfigCore
- PYTHONNAMESPACE PyKF5
- MODULENAME KConfigCore
- RULES_FILE "${CMAKE_SOURCE_DIR}/cmake/rules_PyKF5.py"
- SIP_DEPENDS
- QtCore/QtCoremod.sip
- HEADERS
- kconfig.h
- kconfigbase.h
- kconfiggroup.h
- kdesktopfile.h
- ksharedconfig.h
- kcoreconfigskeleton.h
- kemailsettings.h
- conversioncheck.h
- kconfigwatcher.h
- )
-endif()
-
install(TARGETS KF5ConfigCore EXPORT KF5ConfigTargets ${KF5_INSTALL_TARGETS_DEFAULT_ARGS})
install(FILES