aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Lohnau <alexander.lohnau@gmx.de>2021-11-07 21:34:18 +0100
committerAlexander Lohnau <alexander.lohnau@gmx.de>2021-11-22 09:36:02 +0000
commit3f29f3d6452f735757cb8f84dfc20cdcba791613 (patch)
tree11f40ed6a40cc3368fedfea193f4994c3447348b /CMakeLists.txt
parentc3be6d02f6c061707c6d93e06889a2e56b994d87 (diff)
downloadkconfig-3f29f3d6452f735757cb8f84dfc20cdcba791613.tar.gz
kconfig-3f29f3d6452f735757cb8f84dfc20cdcba791613.tar.bz2
Copy ConfigPropertyMap from KDeclarative to new KConfig QML module
This way consumers which want to use the ConfigPropertyMap don't have to pull in KDeclarative's entire dependency tree. Also we can remove the automatic saving of the config, previously this was opt-out - which makes is difficult to deprecate anything. This way the API design is also more clear, since the object only takes care of exposing the data to QML. The writing has to be done manually, which makes more sense anyways when we have the notify opt-in. As discussed on the KF6 weekly thread, an optional QML submodule is seen as the best way to handle the QML dependency. Task: https://phabricator.kde.org/T12131 Relates to https://phabricator.kde.org/T12126, after his change the KDeclarative stuff can be deprecated. Because we don't register the property map in any QML plugin, there is no conflict in duplicating and modifying it now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 326912b7..64e24647 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ option(KCONFIG_USE_GUI "Build components using Qt5Gui" ON)
if(KCONFIG_USE_GUI)
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Gui)
endif()
+find_package(Qt5 ${REQUIRED_QT_VERSION} OPTIONAL_COMPONENTS Qml)
if (NOT ANDROID)
option(KCONFIG_USE_DBUS "Build components using Qt5DBus" ON)