aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Lohnau <alexander.lohnau@gmx.de>2022-01-15 09:59:58 +0100
committerAlexander Lohnau <alexander.lohnau@gmx.de>2022-01-15 09:59:58 +0100
commit26e541b36d25069fa829e7357aabff1a780f3872 (patch)
treeaf92d5f23dc7e6936e59657d834346a725ed0afc /CMakeLists.txt
parenta05de4ec8be718a0c131a2845da12db7772290a5 (diff)
downloadkconfig-26e541b36d25069fa829e7357aabff1a780f3872.tar.gz
kconfig-26e541b36d25069fa829e7357aabff1a780f3872.tar.bz2
Utilize ECMDeprecationSettings to manage deprecate Qt/KF API
Task: https://phabricator.kde.org/T15109
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2eabc5a1..209d3491 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ include(ECMMarkNonGuiExecutable)
include(ECMPoQmTools)
include(ECMAddQch)
include(ECMQtDeclareLoggingCategory)
+include(ECMDeprecationSettings)
set(REQUIRED_QT_VERSION 5.15.2)
@@ -51,7 +52,9 @@ ecm_setup_version(PROJECT VARIABLE_PREFIX KCONFIG
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5ConfigConfigVersion.cmake"
SOVERSION 5)
-add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f02)
+ecm_set_disabled_deprecation_versions(
+ QT 5.15.2
+)
add_subdirectory(src)
if (BUILD_TESTING)