aboutsummaryrefslogtreecommitdiff
path: root/tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt')
-rw-r--r--tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt b/tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt
index 6162e070..ea62d95b 100644
--- a/tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt
+++ b/tests/KDEInstallDirsTest/not_cache_variable/CMakeLists.txt
@@ -1,10 +1,12 @@
# Test KDEInstallDirs does not crash if a variable like CMAKE_INSTALL_LIBDIR is
# defined but is not a cache variable.
cmake_minimum_required(VERSION 2.8)
-set(kde_modules_dir ${CMAKE_SOURCE_DIR}/../../../kde-modules)
+
+set(ECM_KDE_MODULE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../../kde-modules)
+set(ECM_MODULE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../../modules)
set(CMAKE_INSTALL_LIBDIR "foo")
-include(${kde_modules_dir}/KDEInstallDirs.cmake)
+include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
add_executable(dummy main.c)
set_target_properties(dummy PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})