aboutsummaryrefslogtreecommitdiff
path: root/tests/ECMInstallIconsTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ECMInstallIconsTest/CMakeLists.txt')
-rw-r--r--tests/ECMInstallIconsTest/CMakeLists.txt97
1 files changed, 97 insertions, 0 deletions
diff --git a/tests/ECMInstallIconsTest/CMakeLists.txt b/tests/ECMInstallIconsTest/CMakeLists.txt
new file mode 100644
index 00000000..85f2d9f5
--- /dev/null
+++ b/tests/ECMInstallIconsTest/CMakeLists.txt
@@ -0,0 +1,97 @@
+project(ECMInstallIconsTest)
+cmake_minimum_required(VERSION 2.8.12)
+
+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../modules)
+
+# make sure the test install dir is clean
+file(REMOVE_RECURSE "${CMAKE_INSTALL_PREFIX}")
+
+include(ECMInstallIcons)
+
+add_subdirectory(v1-syntax)
+add_subdirectory(v1-syntax-l10n)
+
+ecm_install_icons(
+ ICONS 16-actions-computer.png
+ DESTINATION single-file-test
+)
+
+ecm_install_icons(
+ ICONS
+ 16-actions-computer.png
+ 16-animations-loading.mng
+ 16-apps-cmake.png
+ 16-categories-system-help.mng
+ 16-emotes-face-smile.png
+ 16-intl-something.png
+ 16-status-user-online.png
+ 128-devices-drive-removable-media-usb-pendrive.png
+ 128-emblems-emblem-mounted.png
+ 128-places-home.mng
+ sc-mimetypes-fonts-package.svgz
+ DESTINATION multi-file-test
+)
+
+ecm_install_icons(
+ ICONS
+ 16-actions-computer.png
+ 16-animations-loading.mng
+ 16-apps-cmake.png
+ 16-categories-system-help.mng
+ 16-emotes-face-smile.png
+ 16-intl-something.png
+ 16-status-user-online.png
+ 128-devices-drive-removable-media-usb-pendrive.png
+ 128-emblems-emblem-mounted.png
+ 128-places-home.mng
+ sc-mimetypes-fonts-package.svgz
+ DESTINATION themed-test
+ THEME theme-name-2
+)
+
+ecm_install_icons(
+ ICONS
+ 16-actions-computer.png
+ 16-animations-loading.mng
+ 16-apps-cmake.png
+ 16-categories-system-help.mng
+ 16-emotes-face-smile.png
+ 16-intl-something.png
+ 16-status-user-online.png
+ 128-devices-drive-removable-media-usb-pendrive.png
+ 128-emblems-emblem-mounted.png
+ 128-places-home.mng
+ sc-mimetypes-fonts-package.svgz
+ DESTINATION lang-test
+ LANG en_US
+)
+
+ecm_install_icons(
+ ICONS
+ 16-actions-computer.png
+ 16-animations-loading.mng
+ 16-apps-cmake.png
+ 16-categories-system-help.mng
+ 16-emotes-face-smile.png
+ 16-intl-something.png
+ 16-status-user-online.png
+ 128-devices-drive-removable-media-usb-pendrive.png
+ 128-emblems-emblem-mounted.png
+ 128-places-home.mng
+ sc-mimetypes-fonts-package.svgz
+ DESTINATION themed-lang-test
+ THEME oxygen
+ LANG en_US
+)
+
+# all these should be warned about
+ecm_install_icons(
+ ICONS
+ aa-actions-badsize.png # ignored
+ badlynamedfile.png # ignored
+ 16-actions-badext.txt # copied
+ DESTINATION badly-named-files-test
+)
+
+# this will be run by CTest
+configure_file(check_tree.cmake.in "${CMAKE_CURRENT_BINARY_DIR}/check_tree.cmake" @ONLY)