aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a44a796..84430c07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,8 @@
-add_subdirectory(automoc)
+if(NOT AUTOMOC4_EXECUTABLE)
+ # this is just a fallback in case automoc4 from kdesupport isn't found, Alex
+ add_subdirectory(automoc)
+endif(NOT AUTOMOC4_EXECUTABLE)
+
add_subdirectory(modules)