aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@kde.org>2014-04-20 15:55:54 +0100
committerAlex Merry <alex.merry@kde.org>2014-04-25 10:43:53 +0100
commiteb8a168c7a184770019d7fcf1dd8ad1a0ba02c80 (patch)
tree361005973f794b22bab8ce0e4a51d8fd47c50e96 /tests/CMakeLists.txt
parentbef4cdd905980b2c8a45a50e2201678c1e4e38af (diff)
downloadextra-cmake-modules-eb8a168c7a184770019d7fcf1dd8ad1a0ba02c80.tar.gz
extra-cmake-modules-eb8a168c7a184770019d7fcf1dd8ad1a0ba02c80.tar.bz2
Split up module execution tests
Find module tests now use find_package(), and there is a version for when CMAKE_MODULE_PATH is set and a version for when ecm_use_find_modules() is used. KDE modules are also now tested. REVIEW 117658
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index b0d7aec9..171f44af 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -19,7 +19,10 @@ macro(ADD_TEST_MACRO NAME COMMAND)
--test-command ${COMMAND} ${ARGN})
endmacro(ADD_TEST_MACRO)
-add_test_macro(ExecuteAllModules ExecuteAllModules)
+add_test_macro(ExecuteCoreModules dummy)
+add_test_macro(ExecuteKDEModules dummy)
+add_test_macro(FindModules dummy)
+add_test_macro(UseFindModules dummy)
set(ECMInstallIconsTest_EXTRA_OPTIONS
--build-target install