aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAleix Pol <aleixpol@kde.org>2017-08-03 16:06:47 +0200
committerAleix Pol <aleixpol@kde.org>2017-08-09 13:09:38 +0200
commite5301edf1daf06aa862eb5ccae5ede72d7717fe0 (patch)
treee6198453926a158d2b494530851832deb5709709 /tests/CMakeLists.txt
parentebbef5afcaee863c62136b14dbd06a7a73cf769a (diff)
downloadextra-cmake-modules-e5301edf1daf06aa862eb5ccae5ede72d7717fe0.tar.gz
extra-cmake-modules-e5301edf1daf06aa862eb5ccae5ede72d7717fe0.tar.bz2
Include a module for finding qml imports as runtime dependencies
Summary: Allows to check if a module is available on the system and sets it as a runtime dependency. This is useful for projects so that they can specify their qml dependencies easily and packagers and developers get to see what's missing by looking at the cmake output. Reviewers: #build_system, #frameworks, sitter Reviewed By: sitter Subscribers: dfaure, aacid Tags: #frameworks, #build_system Differential Revision: https://phabricator.kde.org/D7094
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 7ebcf9b5..cabbe05a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -211,3 +211,16 @@ if (Qt5Core_FOUND AND Qt5LinguistTools_FOUND)
${CMAKE_COMMAND} -P "${CMAKE_CURRENT_BINARY_DIR}/ECMPoQmToolsTest/check.cmake"
)
endif()
+
+find_package(Qt5Quick CONFIG)
+set_package_properties(
+ Qt5Quick
+ PROPERTIES
+ URL "http://www.qt.io/"
+ DESCRIPTION "Qt5 Quick library."
+ TYPE OPTIONAL
+ PURPOSE "Required to run tests for the ECMQMLModules module."
+)
+if (TARGET Qt5::Quick)
+ add_test_macro(ECMQMLModules dummy)
+endif()