aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Cord-Landwehr <cordlandwehr@kde.org>2016-06-13 18:27:24 +0200
committerAndreas Cord-Landwehr <cordlandwehr@kde.org>2016-06-15 15:40:34 +0200
commitc6ae4fa9008b0805f4358012040e67577ba31791 (patch)
tree5d89cbb134678cfacd758a4c9943aa97421049c6 /tests/CMakeLists.txt
parent2503481e4537b88d76b4a596f519cb3311e1ca2a (diff)
downloadextra-cmake-modules-c6ae4fa9008b0805f4358012040e67577ba31791.tar.gz
extra-cmake-modules-c6ae4fa9008b0805f4358012040e67577ba31791.tar.bz2
Integrate relative library paths to APKv5.24.0-rc1v5.24.0
Needed for many unit tests to add them to APK files. REVIEW: 128175
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index a3fbe2e0..dd1350ad 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -40,6 +40,7 @@ add_subdirectory(ECMAddTests)
add_subdirectory(ECMGenerateHeadersTest)
add_subdirectory(ECMSetupVersionTest)
add_subdirectory(ECMGeneratePkgConfigFile)
+add_subdirectory(ECMToolchainAndroidTest)
# a macro for tests that have a simple format where the name matches the
# directory and project
@@ -139,6 +140,8 @@ add_test_macro(ECMInstallIconsTest
${CMAKE_COMMAND} -P "${CMAKE_CURRENT_BINARY_DIR}/ECMInstallIconsTest/check_tree.cmake"
)
+add_test_macro(ECMToolchainAndroidTest dummy)
+
set(KDEPackageAppTemplatesTest_EXTRA_OPTIONS
--build-target install
--build-options