aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@kde.org>2015-07-29 22:46:44 +0200
committerAlex Merry <alex.merry@kde.org>2015-08-18 23:02:11 +0100
commit9bffa7a202cad3a29103f3e9a8b50b9a61277310 (patch)
tree1312c922a8097904a4abc53a2c0d00cd4886ae3f /tests/CMakeLists.txt
parent7af8bdcc7610df1de24c36ceeedd8c9f82529634 (diff)
downloadextra-cmake-modules-9bffa7a202cad3a29103f3e9a8b50b9a61277310.tar.gz
extra-cmake-modules-9bffa7a202cad3a29103f3e9a8b50b9a61277310.tar.bz2
Add macro to generate logging category declarations for Qt5.
This makes life a bit easier for developers who use the categorised logging in Qt5 in the common case - rather than creating two new files, and remembering to put in the #ifdef for the default verbosity settings in Qt 5.4, they can just add a couple of lines to their CMakeLists.txt. REVIEW: 124595
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 7960154a..8a75ae61 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -85,6 +85,9 @@ if (TARGET Qt5::qmake)
add_test_variant(KDEInstallDirsTest.relative_or_absolute_qt
KDEInstallDirsTest.relative_or_absolute dummy)
endif ()
+if (Qt5Core_FOUND)
+ add_test_macro(ECMQtDeclareLoggingCategoryTest testmain)
+endif()
add_test_macro(FindModules dummy)
add_test_macro(UseFindModules dummy)