aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Cord-Landwehr <cordlandwehr@kde.org>2020-09-26 10:32:56 +0000
committerAndreas Cord-Landwehr <cordlandwehr@kde.org>2020-09-26 10:32:56 +0000
commit7e73f1a972f13699c3c2cb80ad50c834b8a8464e (patch)
tree56c80b957ed9f6dd3f5130011ed866ae6512daaf /tests/CMakeLists.txt
parent250932795701e8c6f88bf150dcf4d3668c3173c7 (diff)
downloadextra-cmake-modules-7e73f1a972f13699c3c2cb80ad50c834b8a8464e.tar.gz
extra-cmake-modules-7e73f1a972f13699c3c2cb80ad50c834b8a8464e.tar.bz2
Introduce plausibility check for outbound licenes
When creating a library or executable, several source files are combined into a binary artifact that has an outbound license of its own. This test generator allows to check if the combined source files are compatible with the desired outbound license. Requirements for using these tests: - input source files must contain the SPDX-License-Information tag - python3 must be available - the "reuse spdx" tool must be available
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 866df5bb..1901ca16 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -60,6 +60,11 @@ endmacro()
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/find-modules)
+# enforce finding of ReuseTool in parent scope of module, beause
+# only here the module path can point into the source directory
+find_package(ReuseTool)
+add_subdirectory(ECMCheckOutboundLicenseTest)
+
# Skip if PyQt not available
find_file(SIP_Qt5Core_Mod_FILE
NAMES QtCoremod.sip