aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <kde@randomguy3.me.uk>2014-02-15 16:42:47 +0000
committerAlex Merry <kde@randomguy3.me.uk>2014-02-16 10:49:12 +0000
commit434c63acd090568147505ff1c31053dcb1b3863f (patch)
tree95ae83b51b2bc658d8eaf7113aed5a9cb0552afe /tests/CMakeLists.txt
parent3d931552b72972adb0cefe79cc4d9586671d5224 (diff)
downloadextra-cmake-modules-434c63acd090568147505ff1c31053dcb1b3863f.tar.gz
extra-cmake-modules-434c63acd090568147505ff1c31053dcb1b3863f.tar.bz2
Improve the ECMGenerateHeaders API with a variable for generated files
ecm_generate_headers() now allows/forces the caller to collect the paths of the generated headers, so that they can be passed to the install command. This avoids issues of unexpected files being in the CamelCase includes directory, both from previous builds and because of case-insensitive file systems. MODULE_NAME is removed, as it is no longer desirable or necessary. Instead, the headers are placed directly in the output directory (usually CMAKE_CURRENT_BUILD_DIR). Overall, this makes ecm_generate_headers() behave much more like other file generation macros (like the Qt ones). The old syntax is still supported for now, to make the porting effort easier. REVIEW: 115765
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4347a92d..e464a030 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,5 +1,8 @@
# a macro for tests that have a simple format where the name matches the
# directory and project
+
+add_subdirectory(ECMGenerateHeadersTest)
+
macro(ADD_TEST_MACRO NAME COMMAND)
string(REPLACE "." "/" dir "${NAME}")
string(REGEX REPLACE "[^.]*\\." "" proj "${NAME}")