aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Edmundson <kde@davidedmundson.co.uk>2020-06-08 15:29:40 +0100
committerDavid Edmundson <davidedmundson@kde.org>2020-07-10 12:12:58 +0000
commit0ae520199d0e0523f4f0aa847b7567d72ae9553d (patch)
tree4dc13a76d6dfb691b629962b21abbc2fa5ddfce6 /tests/CMakeLists.txt
parent4ad3d1615f90adc66f053183f82eec572b35d011 (diff)
downloadextra-cmake-modules-0ae520199d0e0523f4f0aa847b7567d72ae9553d.tar.gz
extra-cmake-modules-0ae520199d0e0523f4f0aa847b7567d72ae9553d.tar.bz2
Introduce function ecm_install_configured_file
Summary: This, as the name suggests, configures a file and installs it. It's not very complicated but it's a repeated pattern in plasma that gets quite messy dealing with temporary files. Test Plan: Used in a project Reviewers: #build_system Subscribers: apol, kossebau, pino, kde-frameworks-devel, kde-buildsystem Tags: #frameworks, #build_system Differential Revision: https://phabricator.kde.org/D28355
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5fe100b9..e61d7aa4 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -201,3 +201,13 @@ set_package_properties(
if (TARGET Qt5::Quick)
add_test_macro(ECMQMLModules dummy)
endif()
+
+set(ECMConfiguredInstallTest_EXTRA_OPTIONS
+ --build-target install
+ --build-options
+ "-DCMAKE_INSTALL_PREFIX:PATH=${CMAKE_CURRENT_BINARY_DIR}/ECMConfiguredInstallTest/InstallDirectory"
+)
+add_test_macro(ECMConfiguredInstallTest
+ ${CMAKE_COMMAND} -P "${CMAKE_CURRENT_BINARY_DIR}/ECMConfiguredInstallTest/check_tree.cmake"
+)
+