aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..eda7032
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,41 @@
+# Copyright (C) 2023 Pasha <pasha@bell01.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+AC_PREREQ([2.57])
+
+m4_include([version.m4])
+AC_INIT([AC_PACKAGE_NAME], [AC_PACKAGE_VERSION], [AC_PACKAGE_BUGREPORT],
+ [AC_PACKAGE_TARNAME])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CHECK_LIB(
+[cgroup],
+[cgroup_init],
+[
+ dnl Override the default behavior of AC_CHECK_LIB,
+ dnl we don't want -lcgroup in LIBS.
+ :
+],
+[AC_MSG_ERROR([Cannot compile without libcgroup!])])
+AC_PROG_CC
+AM_PROG_AR
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([
+ Makefile
+ lib/Makefile
+ src/Makefile
+])
+AC_OUTPUT