aboutsummaryrefslogtreecommitdiff
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 403b0367..c7474893 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -13,6 +13,14 @@ target_sources(KF5ConfigGui PRIVATE
kwindowconfig.cpp
)
+ecm_qt_declare_logging_category(KF5ConfigGui
+ HEADER kconfig_gui_log_settings.h
+ IDENTIFIER KCONFIG_GUI_LOG
+ CATEGORY_NAME kf.config.gui
+ DESCRIPTION "KConfig Gui"
+ EXPORT KCONFIG
+)
+
ecm_generate_export_header(KF5ConfigGui
BASE_NAME KConfigGui
GROUP_BASE_NAME KF