aboutsummaryrefslogtreecommitdiff
path: root/tests/ECMInstallIconsTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ECMInstallIconsTest/CMakeLists.txt')
-rw-r--r--tests/ECMInstallIconsTest/CMakeLists.txt23
1 files changed, 16 insertions, 7 deletions
diff --git a/tests/ECMInstallIconsTest/CMakeLists.txt b/tests/ECMInstallIconsTest/CMakeLists.txt
index 85f2d9f5..f048889e 100644
--- a/tests/ECMInstallIconsTest/CMakeLists.txt
+++ b/tests/ECMInstallIconsTest/CMakeLists.txt
@@ -10,6 +10,7 @@ include(ECMInstallIcons)
add_subdirectory(v1-syntax)
add_subdirectory(v1-syntax-l10n)
+add_subdirectory(v1-syntax-no-icons)
ecm_install_icons(
ICONS 16-actions-computer.png
@@ -20,7 +21,7 @@ ecm_install_icons(
ICONS
16-actions-computer.png
16-animations-loading.mng
- 16-apps-cmake.png
+ subdir/16-apps-cmake.png
16-categories-system-help.mng
16-emotes-face-smile.png
16-intl-something.png
@@ -36,7 +37,7 @@ ecm_install_icons(
ICONS
16-actions-computer.png
16-animations-loading.mng
- 16-apps-cmake.png
+ subdir/16-apps-cmake.png
16-categories-system-help.mng
16-emotes-face-smile.png
16-intl-something.png
@@ -53,7 +54,7 @@ ecm_install_icons(
ICONS
16-actions-computer.png
16-animations-loading.mng
- 16-apps-cmake.png
+ subdir/16-apps-cmake.png
16-categories-system-help.mng
16-emotes-face-smile.png
16-intl-something.png
@@ -70,7 +71,7 @@ ecm_install_icons(
ICONS
16-actions-computer.png
16-animations-loading.mng
- 16-apps-cmake.png
+ subdir/16-apps-cmake.png
16-categories-system-help.mng
16-emotes-face-smile.png
16-intl-something.png
@@ -87,11 +88,19 @@ ecm_install_icons(
# all these should be warned about
ecm_install_icons(
ICONS
- aa-actions-badsize.png # ignored
- badlynamedfile.png # ignored
- 16-actions-badext.txt # copied
+ aa-actions-badsize.png # ignored
+ badlynamedfile.png # ignored
+ 16-actions-badext.txt # copied
+ hi16-actions-old-style-name.png # copied
DESTINATION badly-named-files-test
)
+find_program(icon_cache_generator NAMES gtk-update-icon-cache)
+if (icon_cache_generator)
+ set(GENERATE_ICON_CACHE TRUE)
+else()
+ set(GENERATE_ICON_CACHE FALSE)
+endif()
+
# this will be run by CTest
configure_file(check_tree.cmake.in "${CMAKE_CURRENT_BINARY_DIR}/check_tree.cmake" @ONLY)