aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 7ebcf9b5..cabbe05a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -211,3 +211,16 @@ if (Qt5Core_FOUND AND Qt5LinguistTools_FOUND)
${CMAKE_COMMAND} -P "${CMAKE_CURRENT_BINARY_DIR}/ECMPoQmToolsTest/check.cmake"
)
endif()
+
+find_package(Qt5Quick CONFIG)
+set_package_properties(
+ Qt5Quick
+ PROPERTIES
+ URL "http://www.qt.io/"
+ DESCRIPTION "Qt5 Quick library."
+ TYPE OPTIONAL
+ PURPOSE "Required to run tests for the ECMQMLModules module."
+)
+if (TARGET Qt5::Quick)
+ add_test_macro(ECMQMLModules dummy)
+endif()