aboutsummaryrefslogtreecommitdiff
path: root/tests/ECMFindQmlModule/CMakeLists.txt
diff options
context:
space:
mode:
authorArjen Hiemstra <ahiemstra@heimr.nl>2021-08-02 14:56:56 +0200
committerArjen Hiemstra <ahiemstra@heimr.nl>2022-01-18 12:09:57 +0000
commit6fefacf8c4efe8b35aa543514892cbf38cf7b4d9 (patch)
treed5ce029678fc557f35365581fd51e4e5f4d85d03 /tests/ECMFindQmlModule/CMakeLists.txt
parent3813fd1bc97fa6bb2189cc9586f77be4c30478d6 (diff)
downloadextra-cmake-modules-6fefacf8c4efe8b35aa543514892cbf38cf7b4d9.tar.gz
extra-cmake-modules-6fefacf8c4efe8b35aa543514892cbf38cf7b4d9.tar.bz2
Rename ECMQMLModules.cmake to ECMFindQmlModule.cmake
To avoid ambiguity with ECMQmlModule.cmake. To preserve backward compatibility, we keep a version around of ECMQMLModules.cmake that warns a user of it being moved and includes the new file.
Diffstat (limited to 'tests/ECMFindQmlModule/CMakeLists.txt')
-rw-r--r--tests/ECMFindQmlModule/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/ECMFindQmlModule/CMakeLists.txt b/tests/ECMFindQmlModule/CMakeLists.txt
new file mode 100644
index 00000000..c91d0385
--- /dev/null
+++ b/tests/ECMFindQmlModule/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(extra-cmake-modules)
+cmake_minimum_required(VERSION 3.5)
+
+set(ECM_FIND_MODULE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../find-modules)
+set(ECM_MODULE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../modules)
+set(CMAKE_MODULE_PATH "${ECM_FIND_MODULE_DIR}" "${ECM_MODULE_DIR}")
+
+include(ECMFindQmlModule)
+
+ecm_find_qmlmodule(QtQuick 2.1)
+
+add_executable(dummy main.c)