aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Lohnau <alexander.lohnau@gmx.de>2021-01-18 15:08:50 +0100
committerAlexander Lohnau <alexander.lohnau@gmx.de>2021-01-18 15:23:38 +0100
commit7b835ca4d837f22c49f88dabc256569a80692c6d (patch)
tree6ee214133df4e415ca237a01b9080b67bed0349c /CMakeLists.txt
parent1704f7ab86253169615f19a9b10e2a832191b905 (diff)
downloadextra-cmake-modules-7b835ca4d837f22c49f88dabc256569a80692c6d.tar.gz
extra-cmake-modules-7b835ca4d837f22c49f88dabc256569a80692c6d.tar.bz2
Fix permissions for scripts
On Gentoo the permissions are differently set, which causes problems when running cmake. BUG: 431768 FIXED-IN: 5.79
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e346d90..d026713f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,8 +100,7 @@ file(GLOB installKdeModuleFiles LIST_DIRECTORIES FALSE ${CMAKE_SOURCE_DIR}/kde-m
install(FILES ${installKdeModuleFiles} DESTINATION ${KDE_MODULES_INSTALL_DIR})
# The scripts need to be executable
file(GLOB installKDECommitHooks ${CMAKE_SOURCE_DIR}/kde-modules/kde-git-commit-hooks/*[^~])
-install(FILES ${installKDECommitHooks} DESTINATION ${KDE_MODULES_INSTALL_DIR}/kde-git-commit-hooks
- PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ)
+install(PROGRAMS ${installKDECommitHooks} DESTINATION ${KDE_MODULES_INSTALL_DIR}/kde-git-commit-hooks)
file(GLOB installFindModuleFiles ${CMAKE_SOURCE_DIR}/find-modules/*.cmake ${CMAKE_SOURCE_DIR}/find-modules/*.py)
install(FILES ${installFindModuleFiles} DESTINATION ${FIND_MODULES_INSTALL_DIR})