aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-12-18 21:24:11 +0100
committerAlex Neundorf <neundorf@kde.org>2011-12-18 21:24:11 +0100
commitfe76108ad56f0481c80afbf42791a106d7b038ca (patch)
tree4d3367c1e20d4215559321ccbdf340ecc3da622d /CMakeLists.txt
parent9e2e47d30d7a566423a91f1a12e832be0b3948fd (diff)
downloadextra-cmake-modules-fe76108ad56f0481c80afbf42791a106d7b038ca.tar.gz
extra-cmake-modules-fe76108ad56f0481c80afbf42791a106d7b038ca.tar.bz2
-enable testing
-add test ExecuteAllModules, which is the same as FindModulesExecuteAll in CMake: include (and execute) all *cmake files, to make sure they are not completely broken Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20badd37..5ef5fd51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,9 @@ set(ECM_PATCH_VERSION 2)
set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION})
+enable_testing()
+add_subdirectory(tests)
+
set(SHARE_INSTALL_DIR share/extra-cmake-modules-${ECM_VERSION})
set(MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/modules/)
set(FIND_MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/find-modules/)