aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniele E. Domenichelli <ddomenichelli@kde.org>2013-09-26 11:50:55 +0200
committerDaniele E. Domenichelli <ddomenichelli@kde.org>2013-09-26 11:50:55 +0200
commitf3b5aa4ea549f912c57a5c9aeb61f489730984e6 (patch)
treea65a402a39d6d192d9fbf678d4b3117387ebe45d /CMakeLists.txt
parent9b2d1b1e090e8130c332a29329fd7d6df0a02deb (diff)
downloadextra-cmake-modules-f3b5aa4ea549f912c57a5c9aeb61f489730984e6.tar.gz
extra-cmake-modules-f3b5aa4ea549f912c57a5c9aeb61f489730984e6.tar.bz2
Revert "make extra-cmake-modules architecture-independent"
This reverts commit 53679542f663dc74276b928e8749b082319826f4. Since no language has been enabled, the file generated by write_basic_package_version_file does not care about the architecture
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49e90b03..ccd6ea22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,9 @@ configure_package_config_file(ECMConfig.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/ECM
PATH_VARS FIND_MODULES_INSTALL_DIR KDE_MODULES_INSTALL_DIR MODULES_INSTALL_DIR )
-configure_file(ECMConfigVersion.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake @ONLY )
+write_basic_package_version_file( ${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake
+ VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION}
+ COMPATIBILITY AnyNewerVersion )
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ECMConfig.cmake
${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake