aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-07-09 19:02:08 +0200
committerAlex Neundorf <neundorf@kde.org>2011-07-09 19:02:08 +0200
commitbb427ab33a132ea3de1a4bf5d3240961d9d661d1 (patch)
treed387969e33f10646b4a3d93de9e66484d8c69a0f /CMakeLists.txt
parenta88eaa9debf456c561a3faf5a17fe0aff37641ec (diff)
downloadextra-cmake-modules-bb427ab33a132ea3de1a4bf5d3240961d9d661d1.tar.gz
extra-cmake-modules-bb427ab33a132ea3de1a4bf5d3240961d9d661d1.tar.bz2
-generate and install docs
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e89e06a4..a2f9a2b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,18 @@ set(ECM_PATCH_VERSION 1 )
set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION} )
-# need to add a target to create the documentation via cmake --help...
+# create and install docs
+add_custom_target(ManPage ALL
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.1"
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt"
+ )
+
+install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.1" DESTINATION man/man1/ )
+
+install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt" "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
+ DESTINATION share/extra-cmake-modules-${ECM_VERSION}/doc/ )
+
file(GLOB installFiles ${CMAKE_SOURCE_DIR}/modules/*cmake )