aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-07-09 18:53:39 +0200
committerAlex Neundorf <neundorf@kde.org>2011-07-09 18:53:39 +0200
commita88eaa9debf456c561a3faf5a17fe0aff37641ec (patch)
treec3d5a9057b45bc2d59afc0c7a8037b1dce90fc8a /CMakeLists.txt
parentc4b5803fe5b6c93e4e2828fc8472a0f9d81a0bea (diff)
downloadextra-cmake-modules-a88eaa9debf456c561a3faf5a17fe0aff37641ec.tar.gz
extra-cmake-modules-a88eaa9debf456c561a3faf5a17fe0aff37641ec.tar.bz2
Add a version number and an install() rule
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a89a38bb..e89e06a4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,19 @@
-# automoc comes now from kdesupport, Alex
+cmake_minimum_required(VERSION 2.8.0 FATAL_ERROR ) # this will be upgraded to 2.8.6
-add_subdirectory(modules)
+project(extra-cmake-modules)
+set(ECM_MAJOR_VERSION 0 )
+set(ECM_MINOR_VERSION 0 )
+set(ECM_PATCH_VERSION 1 )
+
+set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION} )
+
+# need to add a target to create the documentation via cmake --help...
+
+file(GLOB installFiles ${CMAKE_SOURCE_DIR}/modules/*cmake )
+
+install(FILES ${installFiles} DESTINATION share/extra-cmake-modules-${ECM_VERSION}/modules/ )
+
+# need to install a Config.cmake file
+
+# need to add cpack setup stuff for creating a package