aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-07-12 22:55:40 +0200
committerAlex Neundorf <neundorf@kde.org>2011-07-12 22:55:40 +0200
commit92b87c1d90fbecd23d4a2c50087b8020eea4e089 (patch)
treee2a8880af69a270533f555e3e79cae045e4c2bc3 /CMakeLists.txt
parent0edc7373c81526b4db1e7f5856b037693d7e4efd (diff)
downloadextra-cmake-modules-92b87c1d90fbecd23d4a2c50087b8020eea4e089.tar.gz
extra-cmake-modules-92b87c1d90fbecd23d4a2c50087b8020eea4e089.tar.bz2
-add basic support for packaging
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 784a2c75..d820fec4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,4 +27,11 @@ install(FILES ${installFiles} DESTINATION share/extra-cmake-modules-${ECM_VERSIO
# need to install a Config.cmake file
-# need to add cpack setup stuff for creating a package
+# set up packaging
+set(CPACK_PACKAGE_NAME extra-cmake-modules )
+set(CPACK_PACKAGE_VERSION ${ECM_VERSION})
+set(CPACK_SYSTEM_NAME "generic")
+set(CPACK_GENERATOR "TGZ")
+set(CPACK_SET_DESTDIR FALSE)
+
+include(CPack)