aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-11-29 22:37:07 +0100
committerAlex Neundorf <neundorf@kde.org>2011-11-29 22:37:07 +0100
commit8912ed6d71bf5339518da9eff485d9c64330eeb8 (patch)
tree999239e3f56dfffb6751ec20caf39f008b4d8329 /CMakeLists.txt
parent5b2979f01ccffc07b39750313103e6097ee1e0c7 (diff)
downloadextra-cmake-modules-8912ed6d71bf5339518da9eff485d9c64330eeb8.tar.gz
extra-cmake-modules-8912ed6d71bf5339518da9eff485d9c64330eeb8.tar.bz2
-use the write_basic_config_version_file() macro from cmake 2.8.6
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ee25743..294d9921 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,10 @@ install(FILES ${installFiles} DESTINATION ${MODULES_INSTALL_DIR})
file(RELATIVE_PATH relInstallDir ${CMAKE_INSTALL_PREFIX}/${CMAKECONFIG_INSTALL_DIR} ${CMAKE_INSTALL_PREFIX})
configure_file(extra-cmake-modules-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config.cmake @ONLY)
-configure_file(extra-cmake-modules-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config-version.cmake @ONLY)
+include(WriteBasicConfigVersionFile)
+write_basic_config_version_file( ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config-version.cmake
+ VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION}
+ COMPATIBILITY AnyNewerVersion )
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config.cmake
${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config-version.cmake