aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-12-11 13:31:13 +0100
committerAlex Neundorf <neundorf@kde.org>2011-12-11 13:31:13 +0100
commit69c0c16af749650d58e4f7b2cd24d672147b533b (patch)
tree68538d2d134c55490fb352dd936a29b5e3e2fcda /CMakeLists.txt
parente822807ee6f5390f1cca0662b1da48b64699611a (diff)
downloadextra-cmake-modules-69c0c16af749650d58e4f7b2cd24d672147b533b.tar.gz
extra-cmake-modules-69c0c16af749650d58e4f7b2cd24d672147b533b.tar.bz2
-separate find-modules and other modules into two separate directories, so they can be handled differently (the macros can't clash with stuff from cmake, since they all have the ECM prefix)
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 294d9921..8a43e944 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION})
set(SHARE_INSTALL_DIR share/extra-cmake-modules-${ECM_VERSION})
set(MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/modules/)
+set(FIND_MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/find-modules/)
set(CMAKECONFIG_INSTALL_DIR ${SHARE_INSTALL_DIR}/cmake/)
set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/)
@@ -27,9 +28,11 @@ install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt" "${CMAKE_BINARY_DIR}
DESTINATION ${DOC_INSTALL_DIR})
-file(GLOB installFiles ${CMAKE_SOURCE_DIR}/modules/*[^~])
+file(GLOB installModuleFiles ${CMAKE_SOURCE_DIR}/modules/*[^~])
+install(FILES ${installModuleFiles} DESTINATION ${MODULES_INSTALL_DIR})
-install(FILES ${installFiles} DESTINATION ${MODULES_INSTALL_DIR})
+file(GLOB installFindModuleFiles ${CMAKE_SOURCE_DIR}/find-modules/*[^~])
+install(FILES ${installFindModuleFiles} DESTINATION ${FIND_MODULES_INSTALL_DIR})
# figure out the relative path from the installed Config.cmake file to the install prefix (which may be at
# runtime different from the chosen CMAKE_INSTALL_PREFIX if under Windows the package was installed anywhere)