aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2011-09-17 13:35:13 -0400
committerAllen Winter <allen.winter@kdab.com>2011-09-17 13:35:13 -0400
commit5c8d7e3bbca29dc0a7e7a220fcb0d1de440d15fe (patch)
tree8a13ab338e3620fecf1008319d468f7253759f46 /CMakeLists.txt
parentbf2ecfb4211eab489fca88d3149dcd75bfdc595e (diff)
downloadextra-cmake-modules-5c8d7e3bbca29dc0a7e7a220fcb0d1de440d15fe.tar.gz
extra-cmake-modules-5c8d7e3bbca29dc0a7e7a220fcb0d1de440d15fe.tar.bz2
cleanup per cmakelint.py
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt43
1 files changed, 22 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80306e00..202fcc9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,51 +1,52 @@
-cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR ) # this will be upgraded to 2.8.6
+cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR) # this will be upgraded to 2.8.6
project(extra-cmake-modules)
-set(ECM_MAJOR_VERSION 0 )
-set(ECM_MINOR_VERSION 0 )
-set(ECM_PATCH_VERSION 1 )
+set(ECM_MAJOR_VERSION 0)
+set(ECM_MINOR_VERSION 0)
+set(ECM_PATCH_VERSION 1)
-set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION} )
+set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION})
-set(SHARE_INSTALL_DIR share/extra-cmake-modules-${ECM_VERSION} )
-set(MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/modules/ )
-set(CMAKECONFIG_INSTALL_DIR ${SHARE_INSTALL_DIR}/cmake/ )
-set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/ )
+set(SHARE_INSTALL_DIR share/extra-cmake-modules-${ECM_VERSION})
+set(MODULES_INSTALL_DIR ${SHARE_INSTALL_DIR}/modules/)
+set(CMAKECONFIG_INSTALL_DIR ${SHARE_INSTALL_DIR}/cmake/)
+set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/)
# create and install docs
-add_custom_target(ManPage ALL
- COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.1"
- COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
- COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt"
- )
+add_custom_target(
+ ManPage ALL
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.1"
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt"
+)
-install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.1" DESTINATION man/man1/ )
+install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.1" DESTINATION man/man1/)
install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt" "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
- DESTINATION ${DOC_INSTALL_DIR} )
+ DESTINATION ${DOC_INSTALL_DIR})
-file(GLOB installFiles ${CMAKE_SOURCE_DIR}/modules/*[^~] )
+file(GLOB installFiles ${CMAKE_SOURCE_DIR}/modules/*[^~])
-install(FILES ${installFiles} DESTINATION ${MODULES_INSTALL_DIR} )
+install(FILES ${installFiles} DESTINATION ${MODULES_INSTALL_DIR})
# figure out the relative path from the installed Config.cmake file to the install prefix (which may be at
# runtime different from the chosen CMAKE_INSTALL_PREFIX if under Windows the package was installed anywhere)
# This relative path will be configured into the BarConfig.cmake
-file(RELATIVE_PATH relInstallDir ${CMAKE_INSTALL_PREFIX}/${CMAKECONFIG_INSTALL_DIR} ${CMAKE_INSTALL_PREFIX} )
+file(RELATIVE_PATH relInstallDir ${CMAKE_INSTALL_PREFIX}/${CMAKECONFIG_INSTALL_DIR} ${CMAKE_INSTALL_PREFIX})
configure_file(extra-cmake-modules-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config.cmake @ONLY)
configure_file(extra-cmake-modules-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config-version.cmake @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config.cmake
${CMAKE_CURRENT_BINARY_DIR}/extra-cmake-modules-config-version.cmake
- DESTINATION ${CMAKECONFIG_INSTALL_DIR} )
+ DESTINATION ${CMAKECONFIG_INSTALL_DIR})
# need to install a Config.cmake file
# set up packaging
-set(CPACK_PACKAGE_NAME extra-cmake-modules )
+set(CPACK_PACKAGE_NAME extra-cmake-modules)
set(CPACK_PACKAGE_VERSION ${ECM_VERSION})
set(CPACK_SYSTEM_NAME "generic")
set(CPACK_GENERATOR "TGZ")