aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <arichardson.kde@googlemail.com>2013-09-13 20:37:54 +0200
committerAlex Richardson <arichardson.kde@googlemail.com>2013-09-13 20:37:54 +0200
commit53679542f663dc74276b928e8749b082319826f4 (patch)
treee615f6f903489b71e62aa80bba4282bd6b066a2b /CMakeLists.txt
parentb1bf5ef5a291822750d2869f86b5bba71fc77669 (diff)
downloadextra-cmake-modules-53679542f663dc74276b928e8749b082319826f4.tar.gz
extra-cmake-modules-53679542f663dc74276b928e8749b082319826f4.tar.bz2
make extra-cmake-modules architecture-independent
REVIEW: 112713
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a22f85c..d9a1405b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,9 +49,7 @@ configure_package_config_file(ECMConfig.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/ECM
PATH_VARS FIND_MODULES_INSTALL_DIR KDE_MODULES_INSTALL_DIR MODULES_INSTALL_DIR )
-write_basic_package_version_file( ${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake
- VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION}
- COMPATIBILITY AnyNewerVersion )
+configure_file(ECMConfigVersion.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake @ONLY )
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ECMConfig.cmake
${CMAKE_CURRENT_BINARY_DIR}/ECMConfigVersion.cmake