aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@kde.org>2014-05-28 12:23:36 +0100
committerAlex Merry <alex.merry@kde.org>2014-05-28 16:48:01 +0100
commit51c4739231a637ee600e21e99e2d0bedb78a99e7 (patch)
tree64cd1b6b6f177de18ee81d52108ec81daf1463ec /CMakeLists.txt
parent93fe5c4acbb64988213d295a257ba747f5de554c (diff)
downloadextra-cmake-modules-51c4739231a637ee600e21e99e2d0bedb78a99e7.tar.gz
extra-cmake-modules-51c4739231a637ee600e21e99e2d0bedb78a99e7.tar.bz2
Fix finding of Qt5LinguistTools on some systems
Although ECM does not make use of a compiler directly, the language affects the search path for CMake packages; in particular, a package installed to /usr/lib64/cmake will not be found if NONE is passed as the language argument to project(). This meant that a 64-bit version of Qt5LinguistTools would not be found on systems where 64-bit libraries are not installed in the "default architecture" location (/usr/lib). With this change, the configure step performs some otherwise-unnecessary tests. We minimise this by explicitly specifying the C language (which is also what some of the tests use), rather than letting it be the default (which is C and C++). REVIEW: 118374
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 369bc948..a28d6f4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
-project(extra-cmake-modules NONE)
+# We need to set a language to find CMake packages installed in
+# architecture-dependent locations (like /usr/lib64)
+project(extra-cmake-modules C)
set(ECM_MAJOR_VERSION 0)
set(ECM_MINOR_VERSION 0)