aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@kde.org>2014-06-03 15:22:41 +0100
committerAlex Merry <alex.merry@kde.org>2014-06-17 19:17:05 +0100
commit3afc8f9875979e57cce97edd68a5971d6771e097 (patch)
tree88d7e8d76084fbef5a3574744c8850886475f5a4 /CMakeLists.txt
parent5977afced396a62fb86eb178f13156588e3cfcd8 (diff)
downloadextra-cmake-modules-3afc8f9875979e57cce97edd68a5971d6771e097.tar.gz
extra-cmake-modules-3afc8f9875979e57cce97edd68a5971d6771e097.tar.bz2
Make ECM language-independent again, but make the tests use C
Setting the language for ECM's project() call to C had unanticipated side-effects - notably that the installed version file required the architecture to match the one used at build time. Instead, we make the tests a sub-project, setting up C as the language there (since most of the tests do use C, albeit slightly indirectly). REVIEW: 118498
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df0759f1..a92d621f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,6 @@
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
-# We need to set a language to find CMake packages installed in
-# architecture-dependent locations (like /usr/lib64)
-project(extra-cmake-modules C)
+project(extra-cmake-modules NONE)
set(ECM_MAJOR_VERSION 0)
set(ECM_MINOR_VERSION 0)