aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Merry <kde@randomguy3.me.uk>2012-06-08 22:20:57 +0100
committerAlex Merry <kde@randomguy3.me.uk>2012-09-25 10:25:46 +0100
commit244169e7d2b21b9eb1d7cdf79c6f249eaf8dbb80 (patch)
tree63995789c9d180add0fcf69c75f2672c8133a959 /CMakeLists.txt
parente2e2e6127ab598648ea3b0370f37fd12a0010fb2 (diff)
downloadextra-cmake-modules-244169e7d2b21b9eb1d7cdf79c6f249eaf8dbb80.tar.gz
extra-cmake-modules-244169e7d2b21b9eb1d7cdf79c6f249eaf8dbb80.tar.bz2
Install the ECM man page into section 7
extra-cmake-modules is not a command, so it should not be in section 1 of the man pages. Section 7 (miscellanea) seems most appropriate. REVIEW: 105188
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d591378..391a87d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,13 +20,13 @@ set(DOC_INSTALL_DIR ${SHARE_INSTALL_DIR}/doc/)
# create and install docs
add_custom_target(ManPage ALL
- COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules\;${CMAKE_SOURCE_DIR}/find-modules\;${CMAKE_SOURCE_DIR}/kde-modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.1"
+ COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules\;${CMAKE_SOURCE_DIR}/find-modules\;${CMAKE_SOURCE_DIR}/kde-modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.7"
COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules\;${CMAKE_SOURCE_DIR}/find-modules\;${CMAKE_SOURCE_DIR}/kde-modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
COMMAND ${CMAKE_COMMAND} -DCMAKE_MODULE_PATH=${CMAKE_SOURCE_DIR}/modules\;${CMAKE_SOURCE_DIR}/find-modules\;${CMAKE_SOURCE_DIR}/kde-modules --help-custom-modules "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt"
VERBATIM
)
-install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.1" DESTINATION man/man1/)
+install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.7" DESTINATION man/man7/)
install(FILES "${CMAKE_BINARY_DIR}/extra-cmake-modules.txt" "${CMAKE_BINARY_DIR}/extra-cmake-modules.html"
DESTINATION ${DOC_INSTALL_DIR})