aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAleix Pol <aleixpol@kde.org>2017-04-11 17:19:21 +0200
committerAleix Pol <aleixpol@kde.org>2017-04-11 17:19:21 +0200
commit1eeae4015bca728160f651f781d73851cc4c43ae (patch)
tree301648d1ddfe383cd8578856b1e7503638f3e99e /CMakeLists.txt
parent78529f4452b2e09d9f579d7723f7cb7634f43e7c (diff)
downloadextra-cmake-modules-1eeae4015bca728160f651f781d73851cc4c43ae.tar.gz
extra-cmake-modules-1eeae4015bca728160f651f781d73851cc4c43ae.tar.bz2
Don't include tests together with modules
We have tests that go through the modules directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a209511..a3f47652 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,9 @@ endif()
file(GLOB installModuleFiles ${CMAKE_SOURCE_DIR}/modules/*[^~])
install(FILES ${installModuleFiles} DESTINATION ${MODULES_INSTALL_DIR})
+file(GLOB installTestModuleFiles ${CMAKE_SOURCE_DIR}/test-modules/*[^~])
+install(FILES ${installTestModuleFiles} DESTINATION ${SHARE_INSTALL_DIR}/ECM/test-modules)
+
file(GLOB installKdeModuleFiles ${CMAKE_SOURCE_DIR}/kde-modules/*[^~])
install(FILES ${installKdeModuleFiles} DESTINATION ${KDE_MODULES_INSTALL_DIR})